Apache < 2.0.51 ${ENVVAR} Local Overflow

Low Nessus Network Monitor Plugin ID 2290

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running a vulnerable version of Apache. It is reported that versions prior 2.0.51 are prone to a local buffer overflow when processing ${ENVVAR} constructs in .htaccess and httpd.conf files. An attacker with interactive access to the computer may use this flaw to execute arbitrary code in the context of the web server.

Solution

Upgrade to Apache 2.0.51 or higher.

Plugin Details

Severity: Low

ID: 2290

File Name: 2290.prm

Family: Web Servers

Published: 2004/09/15

Modified: 2016/01/25

Dependencies: 3057

Nessus ID: 14803

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.7

Temporal Score: 2.7

Vector: CVSS2#AV:L/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.0

Reference Information

CVE: CVE-2004-0811, CVE-2004-0809, CVE-2004-0786, CVE-2004-0747

BID: 11239, 11182