Apache < 2.0.51 mod_ssl Rewrite Rules DoS

Medium Nessus Network Monitor Plugin ID 2276


The remote host is vulnerable to a Denial of Service (DoS) attack.


The remote host appears to be running a version of Apache 2.x that is older than 2.0.51. It is reported that these versions of Apache are prone to a denial of service issue related to mod_ssl. An attacker may deny service to legitimate users if the remote server uses a 'RewriteRule' to enable reverse proxying to a SSL origin server.


Upgrade to version 2.0.51 or higher.

Plugin Details

Severity: Medium

ID: 2276

Family: Web Servers

Published: 2004/09/13

Modified: 2016/02/05

Dependencies: 3057

Nessus ID: 14748

Risk Information

Risk Factor: Medium


Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C


Base Score: 5.8

Temporal Score: 5.5


Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.0

Reference Information

CVE: CVE-2004-0786, CVE-2004-0809, CVE-2004-0751

BID: 11154