OpenSSL < 0.9.6m / 0.9.7d Multiple DoS

medium Nessus Network Monitor Plugin ID 2183
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to a Denial of Service (DoS) attack.

Description

The remote host is using a version of OpenSSL that is older than 0.9.6m or 0.9.7d There are several vulnerabilities in this version of OpenSSL that may allow an attacker to cause a denial of service against the remote host.

Solution

Upgrade to version 0.9.6m, 0.9.7d or higher.

See Also

http://www.openssl.org/news/secadv_20040317.txt

http://archives.neohapsis.com/archives/bugtraq/2004-03/0165.html

Plugin Details

Severity: Medium

ID: 2183

Family: Web Servers

Published: 8/30/2004

Updated: 3/6/2019

Dependencies: 5563

Nessus ID: 12110

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2003-0851, CVE-2004-0081, CVE-2004-0079, CVE-2004-0112

BID: 8970, 9899