OpenSSL < 0.9.6m / 0.9.7d Multiple Remote DoS

medium Nessus Plugin ID 12110
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote service is prone to a denial of service attack.

Description

According to its banner, the remote host is using a version of OpenSSL which is older than 0.9.6m / 0.9.7d. There are several bugs in such versions that may allow an attacker to cause a denial of service against the remote host.

Solution

Upgrade to version 0.9.6m / 0.9.7d or newer.

See Also

https://www.openssl.org/news/secadv/20040317.txt

https://seclists.org/bugtraq/2004/Mar/155

Plugin Details

Severity: Medium

ID: 12110

File Name: openssl_denial.nasl

Version: 1.36

Type: remote

Family: Web Servers

Published: 3/17/2004

Updated: 11/15/2018

Dependencies: http_version.nasl, macosx_SecUpd20040503.nasl, redhat-RHSA-2004-119.nasl, redhat-RHSA-2004-120.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Exploit Ease: No known exploits are available

Patch Publication Date: 3/17/2004

Vulnerability Publication Date: 3/17/2004

Reference Information

CVE: CVE-2004-0079, CVE-2004-0081, CVE-2004-0112

BID: 9899