Apache mod_frontpage < 1.6.1 Remote Overflow

High Nessus Network Monitor Plugin ID 1509

Synopsis

The remote Apache server is running mod_frontpage.

Description

The remote Apache server is running mod_frontpage. Versions older than 1.6.1 are vulnerable to a buffer overflow which may allow an attacker to gain root access on this host. *** Note that it is not possible to remotely determine the version of mod_frontpage which is running, so this may be a false positive.

Solution

Upgrade to mod_frontpage 1.6.1 or higher.

Plugin Details

Severity: High

ID: 1509

Family: Web Servers

Published: 2004/08/18

Modified: 2016/11/23

Dependencies: 3057

Nessus ID: 11303

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Reference Information

CVE: CVE-2002-0427

BID: 4251