mod_frontpage for Apache fpexec Remote Overflow

High Nessus Plugin ID 11303


The remote web server module has a buffer overflow vulnerability.


The remote host is using the Apache mod_frontpage module.

mod_frontpage older than 1.6.1 is vulnerable to a buffer overflow that could allow an attacker to gain root access.

*** Since Nessus was not able to remotely determine the version *** of mod_frontage you are running, you are advised to manually *** check which version you are running as this might be a false *** positive.

If you want the remote server to be remotely secure, we advise you do not use this module at all.


Disable this module.

Plugin Details

Severity: High

ID: 11303

File Name: mod_frontpage.nasl

Version: $Revision: 1.20 $

Type: remote

Family: Web Servers

Published: 2003/03/02

Modified: 2014/05/26

Dependencies: 10107

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:christof_pohl:improved_mod_frontpage

Required KB Items: www/apache, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2002/03/07

Reference Information

CVE: CVE-2002-0427

BID: 4251

OSVDB: 14410