Apache < 2.0.43 HTTP POST Request Source Disclosure

Medium Nessus Network Monitor Plugin ID 1489

Synopsis

The remote server is running a web server that is affected by a vulnerability

Description

The remote host is running a version of Apache 2.x which is older than 2.0.43. This version allows an attacker to view the source code of CGI scripts via a POST request made to a directory with both WebDAV and CGI enabled.

Solution

Upgrade to Apache 2.0.43 or higher.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.0

Plugin Details

Severity: Medium

ID: 1489

Family: Web Servers

Published: 2004/08/20

Modified: 2016/01/21

Dependencies: 3057

Nessus ID: 11408

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.0

Reference Information

CVE: CVE-2002-1156

BID: 6065