PHP < 4.3.1 CGI Module File Access

High Nessus Network Monitor Plugin ID 1477

Synopsis

The remote host is running PHP 4.3.0 which contains a flaw which may let anyone execute arbitrary PHP code on this host.

Description

The remote host is running PHP 4.3.0 which contains a flaw which may let anyone execute arbitrary PHP code on this host.

Solution

Upgrade to PHP 4.3.1 or higher.

See Also

http://php.net/ChangeLog-4.php

Plugin Details

Severity: High

ID: 1477

File Name: 1477.prm

Family: Web Servers

Published: 2004/08/20

Modified: 2016/01/15

Dependencies: 8728

Nessus ID: 11237

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2003/02/17

Vulnerability Publication Date: 2003/02/17

Reference Information

CVE: CVE-2003-0097

BID: 6875

OSVDB: 13492