PHP < 4.3.1 CGI Module Force Redirect Settings Bypass Arbitrary File Access

high Nessus Plugin ID 11237


Arbitrary code may be run on the remote server.


The remote host is running PHP 4.3.0.

There is a flaw in this version that could allow an attacker to execute arbitrary PHP code on this host.


Upgrade to PHP 4.3.1 or later.

Plugin Details

Severity: High

ID: 11237

File Name: php_4_3_0.nasl

Version: 1.26

Type: remote

Family: CGI abuses

Published: 2/18/2003

Updated: 5/31/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Patch Publication Date: 2/17/2003

Vulnerability Publication Date: 2/17/2003

Reference Information

CVE: CVE-2003-0097, CVE-2006-4812

BID: 6875

CWE: 94