PHP < 4.3.1 CGI Module Force Redirect Settings Bypass Arbitrary File Access

high Nessus Plugin ID 11237

Synopsis

Arbitrary code may be run on the remote server.

Description

The remote host is running PHP 4.3.0.

There is a flaw in this version that could allow an attacker to execute arbitrary PHP code on this host.

Solution

Upgrade to PHP 4.3.1 or later.

Plugin Details

Severity: High

ID: 11237

File Name: php_4_3_0.nasl

Version: 1.25

Type: remote

Family: CGI abuses

Published: 2/18/2003

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 2/17/2003

Vulnerability Publication Date: 2/17/2003

Reference Information

CVE: CVE-2003-0097, CVE-2006-4812

BID: 6875

CWE: 94