CVS < 1.11.16 / 1.12.8 pserver Line Entry Handling Remote Overflow

Critical Nessus Network Monitor Plugin ID 1220

Synopsis

The remote host is vulnerable to a heap overflow

Description

The remote CVS server, according to its version number, might allow an attacker to execute arbitrary commands on the remote system because of a heap overflow in the cvs pserver code.

Solution

Upgrade to CVS 1.11.16, 1.12.8, or later.

See Also

http://www.nessus.org/u?ac6e8d97

Plugin Details

Severity: Critical

ID: 1220

Family: Generic

Published: 2004/08/20

Modified: 2018/07/11

Dependencies: 1898

Nessus ID: 12240

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:cvs:cvs

Exploitable With

CANVAS (CANVAS)

Reference Information

CVE: CVE-2004-0396

BID: 10384