CVS pserver Line Entry Handling Overflow

Critical Nessus Plugin ID 12240


The remote version control service has a remote heap-based buffer overflow vulnerability.


According to its version number, the remote CVS server has a heap- based buffer overflow vulnerability. A remote attacker could exploit this to crash the service, or possibly execute arbitrary code.


Upgrade to CVS 1.12.8 / 1.11.16 or later.

See Also

Plugin Details

Severity: Critical

ID: 12240

File Name: cvs_pserver_heap_overflow.nasl

Version: $Revision: 1.19 $

Type: remote

Family: Misc.

Published: 2004/05/19

Modified: 2014/05/12

Dependencies: 11384, 17975

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2004/05/19

Exploitable With


Reference Information

CVE: CVE-2004-0396

BID: 10384

OSVDB: 6305