Apache HTTP Server < 2.0.49 mod_ssl Plain HTTP Request DoS

High Nessus Network Monitor Plugin ID 1205

Synopsis

The remote host is vulnerable to a Denial of Service (DoS) attack

Description

The remote host appears to be running a version of Apache 2.x which is older than 2.0.49. There is a bug in the mod_ssl module that ships with Apache 2.0.35 to 2.0.48 that makes it vulnerable to a remote denial of service. An attacker may exploit this flaw by issuing malformed SSL commands when connecting to the remote host, and may therefore use it to prevent HTTPS from working.

Solution

Upgrade to Apache/2.0.49 or later.

Plugin Details

Severity: High

ID: 1205

Family: Web Servers

Published: 2004/08/20

Modified: 2016/02/05

Dependencies: 1723, 3057

Nessus ID: 12100

Risk Information

Risk Factor: High

CVSSv2

Base Score: 8.8

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.4

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Reference Information

CVE: CVE-2004-0113

BID: 9826