Apache 2.0.x < 2.0.49 mod_ssl Plain HTTP Request DoS

Medium Nessus Plugin ID 12100


The remote web server is affected by a denial of service vulnerability.


The remote host appears to be running a version of Apache 2.0.x prior to 2.0.49. It is, therefore, affected by a denial of service vulnerability in the 'mod_ssl' module. An attacker can exploit this to deny service to the Apache server.


Upgrade to Apache web server version 2.0.49 or later.

Plugin Details

Severity: Medium

ID: 12100

File Name: apache_2_0_49_mod_ssl.nasl

Version: $Revision: 1.26 $

Type: remote

Family: Web Servers

Published: 2004/03/14

Modified: 2018/01/23

Dependencies: 48204

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2004/02/20

Reference Information

CVE: CVE-2004-0113

BID: 9826

OSVDB: 4182

Secunia: 11092, 11705