Fortinet FortiOS 5.2.x < 5.2.11 srcintf XSS (FG-IR-17-017)

Low Nessus Plugin ID 99969

Synopsis

The remote host is affected by a cross-site scripting vulnerability.

Description

The version of Fortinet FortiOS running on the remote FortiGate device is 5.2.x prior to 5.2.11. It is, therefore, affected by a cross-site scripting (XSS) vulnerability when creating firewall policies due to improper validation of input related to srcintf before returning it to users. An authenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.

Solution

Upgrade to Fortinet FortiOS version 5.2.11 or later.

See Also

http://fortiguard.com/psirt/FG-IR-17-017

Plugin Details

Severity: Low

ID: 99969

File Name: fortios_FG-IR-17-017.nasl

Version: $Revision: 1.3 $

Type: local

Family: Firewalls

Published: 2017/05/03

Modified: 2017/08/14

Dependencies: 73522

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.5

Temporal Score: 2.9

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 4.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/o:fortinet:fortios

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/04/19

Vulnerability Publication Date: 2017/04/19

Reference Information

CVE: CVE-2017-3127

BID: 98048