EulerOS 2.0 SP1 : firefox (EulerOS-SA-2017-1048)

High Nessus Plugin ID 99893


The remote EulerOS host is missing multiple security updates.


According to the versions of the firefox package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities :

- Multiple flaws were found in the processing of malformed web content. A web page containing malicious content could cause Firefox to crash or, potentially, execute arbitrary code with the privileges of the user running Firefox. (CVE-2017-5398, CVE-2017-5400, CVE-2017-5401, CVE-2017-5402, CVE-2017-5404, CVE-2017-5407, CVE-2017-5408, CVE-2017-5410, CVE-2017-5405,CVE-2017-5428)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected firefox packages.

See Also

Plugin Details

Severity: High

ID: 99893

File Name: EulerOS_SA-2017-1048.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2017/05/01

Modified: 2017/08/14

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:firefox, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/03/09

Reference Information

CVE: CVE-2017-5398, CVE-2017-5400, CVE-2017-5401, CVE-2017-5402, CVE-2017-5404, CVE-2017-5405, CVE-2017-5407, CVE-2017-5408, CVE-2017-5410, CVE-2017-5428

OSVDB: 153143, 153173, 153174, 153175, 153176, 153177, 153178, 153179, 153180, 153181, 153182, 153183, 153190, 153191, 153192, 153193, 153195, 153198, 153214, 153959