MySQL Cluster 7.4.x < 7.4.15 DD Subcomponent Arbitrary Data Manipulation (April 2017 CPU)

Medium Nessus Plugin ID 99519


The remote database server is affected by an arbitrary data manipulation vulnerability.


The version of MySQL Cluster running on the remote host is 7.4.x prior to 7.4.15. It is, therefore, affected by an arbitrary data manipulation vulnerability in the DD subcomponent due to an unspecified flaw. An authenticated, remote attacker can exploit this to update, insert, or delete arbitrary data or cause a partial denial of service condition.


Upgrade to MySQL Cluster version 7.4.15 or later as referenced in the April 2017 Oracle Critical Patch Update advisory.

See Also

Plugin Details

Severity: Medium

ID: 99519

File Name: mysql_cluster_7_4_15.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Databases

Published: 2017/04/20

Modified: 2017/08/15

Dependencies: 10719

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:oracle:mysql_cluster

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/04/10

Vulnerability Publication Date: 2017/04/18

Reference Information

CVE: CVE-2017-3304

BID: 97815

OSVDB: 155885