MySQL Cluster 7.2.x < 7.2.28 DD Subcomponent Arbitrary Data Manipulation (April 2017 CPU)

Medium Nessus Plugin ID 99517

Synopsis

The remote database server is affected by an arbitrary data manipulation vulnerability.

Description

The version of MySQL Cluster running on the remote host is 7.2.x prior to 7.2.28. It is, therefore, affected by an arbitrary data manipulation vulnerability in the DD subcomponent due to an unspecified flaw. An authenticated, remote attacker can exploit this to update, insert, or delete arbitrary data or cause a partial denial of service condition.

Solution

Upgrade to MySQL Cluster version 7.2.28 or later as referenced in the April 2017 Oracle Critical Patch Update advisory.

See Also

http://www.nessus.org/u?86ad1d21

http://www.nessus.org/u?d679be85

http://www.nessus.org/u?eb4db3c7

Plugin Details

Severity: Medium

ID: 99517

File Name: mysql_cluster_7_2_28.nasl

Version: 1.8

Type: remote

Family: Databases

Published: 2017/04/20

Modified: 2018/11/15

Dependencies: 10719, 91823

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql_cluster

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/04/10

Vulnerability Publication Date: 2017/04/18

Reference Information

CVE: CVE-2017-3304

BID: 97815