MySQL 5.5.x < 5.5.55 Multiple Vulnerabilities (April 2017 CPU) (Riddle)

High Nessus Plugin ID 99514

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL running on the remote host is 5.5.x prior to 5.5.55. It is, therefore, affected by multiple vulnerabilities :

- A use-after-free error exists in the mysql_prune_stmt_list() function in client.c that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2017-3302)

- An authentication information disclosure vulnerability, known as Riddle, exists due to authentication being performed prior to security parameter verification. A man-in-the-middle (MitM) attacker can exploit this vulnerability to disclose sensitive authentication information, which the attacker can later use for authenticating to the server. (CVE-2017-3305)

- Multiple unspecified flaws exist in the DML subcomponent that allow an authenticated, remote attacker to cause a denial of service condition. (CVE-2017-3308, CVE-2017-3456)

- Multiple unspecified flaws exist in the Optimizer subcomponent that allow an authenticated, remote attacker to cause a denial of service condition.
(CVE-2017-3309, CVE-2017-3453)

- An unspecified flaw exists in the Thread Pooling subcomponent that allows an unauthenticated, remote attacker to update, insert, or delete data contained in the database. (CVE-2017-3329)

- Multiple unspecified flaws exist in the 'Security: Privileges' subcomponent that allow an authenticated, remote attacker to cause a denial of service condition. (CVE-2017-3461, CVE-2017-3462, CVE-2017-3463)

- An unspecified flaw exists in the DDL subcomponent that allows an authenticated, remote attacker to update, insert, or delete data contained in the database.
(CVE-2017-3464)

- An unspecified flaw exists in the 'Client mysqldump' subcomponent that allows an authenticated, remote attacker to execute arbitrary code. (CVE-2017-3600)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MySQL version 5.5.55 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-55.html

http://www.nessus.org/u?d679be85

http://www.nessus.org/u?eb4db3c7

https://support.oracle.com/rs?type=doc&id=2244179.1

http://riddle.link/

Plugin Details

Severity: High

ID: 99514

File Name: mysql_5_5_55.nasl

Version: 1.12

Type: remote

Family: Databases

Published: 2017/04/20

Modified: 2018/11/15

Dependencies: 91823, 10719

Risk Information

Risk Factor: High

CVSS Score Source: manual

CVSS Score Rationale: Score from a more in depth analysis done by tenable

CVSS v2.0

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.6

Temporal Score: 5.8

Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/04/10

Vulnerability Publication Date: 2011/12/19

Reference Information

CVE: CVE-2017-3302, CVE-2017-3305, CVE-2017-3308, CVE-2017-3309, CVE-2017-3329, CVE-2017-3453, CVE-2017-3456, CVE-2017-3461, CVE-2017-3462, CVE-2017-3463, CVE-2017-3464, CVE-2017-3600

BID: 96162, 97023, 97725, 97742, 97763, 97765, 97776, 97812, 97818, 97831, 97849, 97851