openSUSE Security Update : libpng15 (openSUSE-2017-477)

High Nessus Plugin ID 99428


The remote openSUSE host is missing a security update.


This update for libpng15 fixes the following issues :

Security issues fixed :

- CVE-2015-8540: read underflow in libpng (bsc#958791)

- CVE-2016-10087: NULL pointer dereference in png_set_text_2() (bsc#1017646)

This update was imported from the SUSE:SLE-12-SP1:Update update project.


Update the affected libpng15 packages.

See Also

Plugin Details

Severity: High

ID: 99428

File Name: openSUSE-2017-477.nasl

Version: $Revision: 3.2 $

Type: local

Agent: unix

Published: 2017/04/18

Modified: 2017/04/20

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libpng15-15, p-cpe:/a:novell:opensuse:libpng15-15-32bit, p-cpe:/a:novell:opensuse:libpng15-15-debuginfo, p-cpe:/a:novell:opensuse:libpng15-15-debuginfo-32bit, p-cpe:/a:novell:opensuse:libpng15-debugsource, cpe:/o:novell:opensuse:42.1, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/04/18

Reference Information

CVE: CVE-2015-8540, CVE-2016-10087