openSUSE Security Update : postgresql93 (openSUSE-2017-472)

Medium Nessus Plugin ID 99417

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for postgresql93 to version 9.3.14 fixes the several issues.

These security issues were fixed :

- CVE-2016-5423: CASE/WHEN with inlining can cause untrusted pointer dereference (bsc#993454).

- CVE-2016-5424: Fix client programs' handling of special characters in database and role names (bsc#993453).

This non-security issue was fixed :

- bsc#973660: Added 'Requires: timezone' to Service Pack

- bsc#1029547: postgresql: fails to build with timezone 2017a

For additional non-security issues please refer to

- http://www.postgresql.org/docs/9.3/static/release-9-3-14.html

- http://www.postgresql.org/docs/9.3/static/release-9-3-13.html

- http://www.postgresql.org/docs/9.4/static/release-9-3-12.html

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected postgresql93 packages.

See Also

https://www.postgresql.org/docs/9.3/release-9-3-13.html

https://www.postgresql.org/docs/9.3/release-9-3-14.html

https://www.postgresql.org/docs/9.4/release-9-3-12.html

https://bugzilla.opensuse.org/show_bug.cgi?id=1029547

https://bugzilla.opensuse.org/show_bug.cgi?id=973660

https://bugzilla.opensuse.org/show_bug.cgi?id=993453

https://bugzilla.opensuse.org/show_bug.cgi?id=993454

Plugin Details

Severity: Medium

ID: 99417

File Name: openSUSE-2017-472.nasl

Version: 3.4

Type: local

Agent: unix

Published: 2017/04/17

Updated: 2018/12/18

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.3

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:postgresql93, p-cpe:/a:novell:opensuse:postgresql93-contrib, p-cpe:/a:novell:opensuse:postgresql93-contrib-debuginfo, p-cpe:/a:novell:opensuse:postgresql93-debuginfo, p-cpe:/a:novell:opensuse:postgresql93-debugsource, p-cpe:/a:novell:opensuse:postgresql93-devel, p-cpe:/a:novell:opensuse:postgresql93-devel-debuginfo, p-cpe:/a:novell:opensuse:postgresql93-libs-debugsource, p-cpe:/a:novell:opensuse:postgresql93-plperl, p-cpe:/a:novell:opensuse:postgresql93-plperl-debuginfo, p-cpe:/a:novell:opensuse:postgresql93-plpython, p-cpe:/a:novell:opensuse:postgresql93-plpython-debuginfo, p-cpe:/a:novell:opensuse:postgresql93-pltcl, p-cpe:/a:novell:opensuse:postgresql93-pltcl-debuginfo, p-cpe:/a:novell:opensuse:postgresql93-server, p-cpe:/a:novell:opensuse:postgresql93-server-debuginfo, p-cpe:/a:novell:opensuse:postgresql93-test, cpe:/o:novell:opensuse:42.1, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/04/15

Reference Information

CVE: CVE-2016-5423, CVE-2016-5424