openSUSE Security Update : atheme (openSUSE-2017-456)

High Nessus Plugin ID 99294


The remote openSUSE host is missing a security update.


This update for atheme fixes the following issues :

- CVE-2017-6384: Memory leak in the login_user function allowing for DoS (boo#1027614)

- Use after free that could potentially be used by an attacker already having the privilege to use SASL impersonation to cause a denial of service.

This update also contains a number of upstream bug fixes.


Update the affected atheme packages.

See Also

Plugin Details

Severity: High

ID: 99294

File Name: openSUSE-2017-456.nasl

Version: $Revision: 3.2 $

Type: local

Agent: unix

Published: 2017/04/12

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C


Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:atheme, p-cpe:/a:novell:opensuse:atheme-debuginfo, p-cpe:/a:novell:opensuse:atheme-debugsource, p-cpe:/a:novell:opensuse:atheme-devel, p-cpe:/a:novell:opensuse:libathemecore1, p-cpe:/a:novell:opensuse:libathemecore1-debuginfo, cpe:/o:novell:opensuse:42.1, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/04/11

Reference Information

CVE: CVE-2017-6384