Cisco IOS XE Web User Interface DoS (cisco-sa-20170322-webui)

high Nessus Plugin ID 99031

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

According to its self-reported version, the Cisco IOS XE software running on the remote device is affected by a denial of service vulnerability in the web user interface due to insufficient resource handling. An unauthenticated, remote attacker can exploit this issue, by sending a high number of requests to the web user interface, to cause the device to reload.

Note that for this vulnerability to be exploited, the web user interface must be enabled and publicly exposed. Typically, it is connected to a restricted management network. By default, the web user interface is not enabled.

Solution

Upgrade to the relevant fixed version referenced in Cisco bug ID CSCup70353.

See Also

http://www.nessus.org/u?072bd138

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCup70353

Plugin Details

Severity: High

ID: 99031

File Name: cisco-sa-20170322-webui.nasl

Version: 1.8

Type: local

Family: CISCO

Published: 3/29/2017

Updated: 11/13/2019

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:cisco:ios_xe

Required KB Items: Host/Cisco/IOS-XE/Version

Exploit Ease: No known exploits are available

Patch Publication Date: 3/22/2017

Vulnerability Publication Date: 3/22/2017

Reference Information

CVE: CVE-2017-3856

BID: 97007

CISCO-BUG-ID: CSCup70353

CISCO-SA: cisco-sa-20170322-webui