SUSE SLED12 / SLES12 Security Update : qemu (SUSE-SU-2017:0625-1)

High Nessus Plugin ID 97599

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for qemu fixes several issues. These security issues were fixed :

- CVE-2017-5898: The CCID Card device emulator support was vulnerable to an integer overflow flaw allowing a privileged user to crash the Qemu process on the host resulting in DoS (bsc#1023907).

- CVE-2017-5857: The Virtio GPU Device emulator support was vulnerable to a host memory leakage issue allowing a guest user to leak host memory resulting in DoS (bsc#1023073).

- CVE-2017-2620: In CIRRUS_BLTMODE_MEMSYSSRC mode the bitblit copy routine cirrus_bitblt_cputovideo failed to check the memory region, allowing for an out-of-bounds write that allows for privilege escalation (bsc#1024972)

- CVE-2017-2615: An error in the bitblt copy operation could have allowed a malicious guest administrator to cause an out of bounds memory access, possibly leading to information disclosure or privilege escalation (bsc#1023004)

- CVE-2017-5856: The MegaRAID SAS 8708EM2 Host Bus Adapter emulation support was vulnerable to a memory leakage issue allowing a privileged user to leak host memory resulting in DoS (bsc#1023053)

- CVE-2016-9921: The Cirrus CLGD 54xx VGA Emulator support was vulnerable to a divide by zero issue while copying VGA data. A privileged user inside guest could have used this flaw to crash the process instance on the host, resulting in DoS (bsc#1014702)

- CVE-2016-9922: The Cirrus CLGD 54xx VGA Emulator support was vulnerable to a divide by zero issue while copying VGA data. A privileged user inside guest could have used this flaw to crash the process instance on the host, resulting in DoS (bsc#1014702)

- CVE-2016-10029: The Virtio GPU Device emulator support was vulnerable to an OOB read issue allowing a guest user to crash the Qemu process instance resulting in Dos (bsc#1017081).

- CVE-2016-10028: The Virtio GPU Device emulator support was vulnerable to an out of bounds memory access issue allowing a guest user to crash the Qemu process instance on a host, resulting in DoS (bsc#1017084).

- CVE-2016-10155: The virtual hardware watchdog 'wdt_i6300esb' was vulnerable to a memory leakage issue allowing a privileged user to cause a DoS and/or potentially crash the Qemu process on the host (bsc#1021129)

- CVE-2017-5552: The Virtio GPU Device emulator support was vulnerable to a memory leakage issue allowing a guest user to leak host memory resulting in DoS (bsc#1021195).

- CVE-2017-5578: The Virtio GPU Device emulator support was vulnerable to a memory leakage issue allowing a guest user to leak host memory resulting in DoS (bsc#1021481).

- CVE-2017-5526: The ES1370 audio device emulation support was vulnerable to a memory leakage issue allowing a privileged user inside the guest to cause a DoS and/or potentially crash the Qemu process on the host (bsc#1020589).

- CVE-2017-5525: The ac97 audio device emulation support was vulnerable to a memory leakage issue allowing a privileged user inside the guest to cause a DoS and/or potentially crash the Qemu process on the host (bsc#1020491).

- CVE-2017-5667: The SDHCI device emulation support was vulnerable to an OOB heap access issue allowing a privileged user inside the guest to crash the Qemu process resulting in DoS or potentially execute arbitrary code with privileges of the Qemu process on the host (bsc#1022541).

- CVE-2017-5898: The CCID Card device emulator support was vulnerable to an integer overflow allowing a privileged user inside the guest to crash the Qemu process resulting in DoS (bnc#1023907)

The update package also includes non-security fixes. See advisory for details.

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:zypper in -t patch SUSE-SLE-RPI-12-SP2-2017-336=1

SUSE Linux Enterprise Server 12-SP2:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2017-336=1

SUSE Linux Enterprise Desktop 12-SP2:zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2017-336=1

To bring your system up-to-date, use 'zypper patch'.

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1014702

https://bugzilla.suse.com/show_bug.cgi?id=1015169

https://bugzilla.suse.com/show_bug.cgi?id=1016779

https://bugzilla.suse.com/show_bug.cgi?id=1017081

https://bugzilla.suse.com/show_bug.cgi?id=1017084

https://bugzilla.suse.com/show_bug.cgi?id=1020491

https://bugzilla.suse.com/show_bug.cgi?id=1020589

https://bugzilla.suse.com/show_bug.cgi?id=1020928

https://bugzilla.suse.com/show_bug.cgi?id=1021129

https://bugzilla.suse.com/show_bug.cgi?id=1021195

https://bugzilla.suse.com/show_bug.cgi?id=1021481

https://bugzilla.suse.com/show_bug.cgi?id=1022541

https://bugzilla.suse.com/show_bug.cgi?id=1023004

https://bugzilla.suse.com/show_bug.cgi?id=1023053

https://bugzilla.suse.com/show_bug.cgi?id=1023073

https://bugzilla.suse.com/show_bug.cgi?id=1023907

https://bugzilla.suse.com/show_bug.cgi?id=1024972

https://bugzilla.suse.com/show_bug.cgi?id=1026583

https://bugzilla.suse.com/show_bug.cgi?id=977027

https://www.suse.com/security/cve/CVE-2016-10028/

https://www.suse.com/security/cve/CVE-2016-10029/

https://www.suse.com/security/cve/CVE-2016-10155/

https://www.suse.com/security/cve/CVE-2016-9921/

https://www.suse.com/security/cve/CVE-2016-9922/

https://www.suse.com/security/cve/CVE-2017-2615/

https://www.suse.com/security/cve/CVE-2017-2620/

https://www.suse.com/security/cve/CVE-2017-5525/

https://www.suse.com/security/cve/CVE-2017-5526/

https://www.suse.com/security/cve/CVE-2017-5552/

https://www.suse.com/security/cve/CVE-2017-5578/

https://www.suse.com/security/cve/CVE-2017-5667/

https://www.suse.com/security/cve/CVE-2017-5856/

https://www.suse.com/security/cve/CVE-2017-5857/

https://www.suse.com/security/cve/CVE-2017-5898/

http://www.nessus.org/u?820cfde9

Plugin Details

Severity: High

ID: 97599

File Name: suse_SU-2017-0625-1.nasl

Version: 3.16

Type: local

Agent: unix

Published: 2017/03/08

Updated: 2019/09/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.9

Temporal Score: 8.6

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:qemu, p-cpe:/a:novell:suse_linux:qemu-block-curl, p-cpe:/a:novell:suse_linux:qemu-block-curl-debuginfo, p-cpe:/a:novell:suse_linux:qemu-block-rbd, p-cpe:/a:novell:suse_linux:qemu-block-rbd-debuginfo, p-cpe:/a:novell:suse_linux:qemu-block-ssh, p-cpe:/a:novell:suse_linux:qemu-block-ssh-debuginfo, p-cpe:/a:novell:suse_linux:qemu-debugsource, p-cpe:/a:novell:suse_linux:qemu-guest-agent, p-cpe:/a:novell:suse_linux:qemu-guest-agent-debuginfo, p-cpe:/a:novell:suse_linux:qemu-kvm, p-cpe:/a:novell:suse_linux:qemu-lang, p-cpe:/a:novell:suse_linux:qemu-tools, p-cpe:/a:novell:suse_linux:qemu-tools-debuginfo, p-cpe:/a:novell:suse_linux:qemu-x86, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/03/07

Vulnerability Publication Date: 2016/12/23

Reference Information

CVE: CVE-2016-10028, CVE-2016-10029, CVE-2016-10155, CVE-2016-9921, CVE-2016-9922, CVE-2017-2615, CVE-2017-2620, CVE-2017-5525, CVE-2017-5526, CVE-2017-5552, CVE-2017-5578, CVE-2017-5667, CVE-2017-5856, CVE-2017-5857, CVE-2017-5898

IAVB: 2017-B-0024