SUSE SLES11 Security Update : openssh (SUSE-SU-2017:0606-1)

High Nessus Plugin ID 97570

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for openssh fixes the following issues: Security issues fixed :

- CVE-2016-8858: prevent resource depletion during key exchange (bsc#1005480)

- CVE-2016-10009: limit directories for loading PKCS11 modules to avoid privilege escalation (bsc#1016366)

- CVE-2016-10011: Prevent possible leaks of host private keys to low-privilege process handling authentication (bsc#1016369) Non security issues fixed :

- Properly verify CIDR masks in the AllowUsers and DenyUsers configuration lists (bsc#1005893)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE OpenStack Cloud 5:zypper in -t patch sleclo50sp3-openssh-13005=1

SUSE Manager Proxy 2.1:zypper in -t patch slemap21-openssh-13005=1

SUSE Manager 2.1:zypper in -t patch sleman21-openssh-13005=1

SUSE Linux Enterprise Server 11-SP3-LTSS:zypper in -t patch slessp3-openssh-13005=1

SUSE Linux Enterprise Point of Sale 11-SP3:zypper in -t patch sleposp3-openssh-13005=1

SUSE Linux Enterprise Debuginfo 11-SP3:zypper in -t patch dbgsp3-openssh-13005=1

To bring your system up-to-date, use 'zypper patch'.

See Also

https://bugzilla.suse.com/show_bug.cgi?id=1005480

https://bugzilla.suse.com/show_bug.cgi?id=1005893

https://bugzilla.suse.com/show_bug.cgi?id=1016366

https://bugzilla.suse.com/show_bug.cgi?id=1016369

https://www.suse.com/security/cve/CVE-2016-10009/

https://www.suse.com/security/cve/CVE-2016-10011/

https://www.suse.com/security/cve/CVE-2016-8858/

http://www.nessus.org/u?67b25b28

Plugin Details

Severity: High

ID: 97570

File Name: suse_SU-2017-0606-1.nasl

Version: 3.4

Type: local

Agent: unix

Published: 2017/03/07

Updated: 2018/11/30

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:openssh, p-cpe:/a:novell:suse_linux:openssh-askpass, p-cpe:/a:novell:suse_linux:openssh-askpass-gnome, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/03/06

Reference Information

CVE: CVE-2016-10009, CVE-2016-10011, CVE-2016-8858