McAfee ePolicy Orchestrator 5.1.x < 5.1.3 HF1110787 Computer Management Services XSS (SB10184)

Low Nessus Plugin ID 97417

Synopsis

A security management application installed on the remote Windows host is affected by a reflected cross-site scripting vulnerability.

Description

The version of McAfee ePolicy Orchestrator (ePO) installed on the remote Windows host is 5.1.x prior to 5.1.3 hotfix 1110787. It is, therefore, affected by a reflected cross-site scripting (XSS) vulnerability in the web user interface (UI), specifically within the ePO computer management services, due to a failure to properly validate user-supplied input to unspecified parameters. An authenticated, remote attacker can exploit this vulnerability, by convincing a user into requesting a specially crafted URL, to execute arbitrary script code in the user's browser session.

Solution

Upgrade to McAfee ePO version 5.1.3 hotfix 1110787 or later.

See Also

https://kc.mcafee.com/corporate/index?page=content&id=SB10184

Plugin Details

Severity: Low

ID: 97417

File Name: mcafee_epo_sb10184.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2017/02/27

Modified: 2017/03/01

Dependencies: 67119

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.5

Temporal Score: 2.9

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 4.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:mcafee:epolicy_orchestrator

Required KB Items: SMB/Registry/Enumerated, installed_sw/McAfee ePO

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/01/17

Vulnerability Publication Date: 2017/01/17

Reference Information

CVE: CVE-2017-3902

MCAFEE-SB: SB10184