openSUSE Security Update : profanity (openSUSE-2017-285)

Medium Nessus Plugin ID 97315


The remote openSUSE host is missing a security update.


This update for profanity fixes the following issues :

Changes in profanity :

- CVE-2017-5592: The incorrect message carbons implementation that could allow user impersonification was fixed (boo#1024696)


Update the affected profanity packages.

See Also

Plugin Details

Severity: Medium

ID: 97315

File Name: openSUSE-2017-285.nasl

Version: $Revision: 3.1 $

Type: local

Agent: unix

Published: 2017/02/22

Modified: 2017/02/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N


Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:profanity, p-cpe:/a:novell:opensuse:profanity-debuginfo, p-cpe:/a:novell:opensuse:profanity-debugsource, p-cpe:/a:novell:opensuse:profanity-mini, p-cpe:/a:novell:opensuse:profanity-mini-debuginfo, p-cpe:/a:novell:opensuse:profanity-standard, p-cpe:/a:novell:opensuse:profanity-standard-debuginfo, cpe:/o:novell:opensuse:42.1, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/02/21

Reference Information

CVE: CVE-2017-5592