Tenable Nessus 6.8.x and 6.9.x < 6.9.1 Stored XSS (TNS-2016-17)

Medium Nessus Plugin ID 97193


An application running on the remote host is affected by a stored cross-site scripting vulnerability.


According to its self-reported version number, the Tenable Nessus application running on the remote host is 6.8.x or 6.9.x prior to 6.9.1. It is, therefore, affected by a stored cross-site scripting (XSS) vulnerability due to improper validation of user-supplied input.
An authenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.


Upgrade to Tenable Nessus version 6.9.1 or later.

See Also


Plugin Details

Severity: Medium

ID: 97193

File Name: nessus_tns_2016_17.nasl

Version: $Revision: 1.2 $

Type: remote

Published: 2017/02/15

Modified: 2017/02/17

Dependencies: 10147

Risk Information

Risk Factor: Medium


Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 4.3

Temporal Score: 4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:tenable:nessus

Required KB Items: installed_sw/nessus

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/11/09

Vulnerability Publication Date: 2016/11/09

Reference Information

CVE: CVE-2016-9259

OSVDB: 147028