GLSA-201701-47 : cURL: Multiple vulnerabilities

High Nessus Plugin ID 96644


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-47 (cURL: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in cURL. Please review the CVE identifiers and bug reports referenced for details.
Impact :

Remote attackers could conduct a Man-in-the-Middle attack to obtain sensitive information, cause a Denial of Service condition, or execute arbitrary code.
Workaround :

There is no known workaround at this time.


All cURL users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/curl-7.52.1'

See Also

Plugin Details

Severity: High

ID: 96644

File Name: gentoo_GLSA-201701-47.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/20

Modified: 2017/01/20

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:curl, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/19

Reference Information

CVE: CVE-2014-8150, CVE-2014-8151, CVE-2016-0755, CVE-2016-3739, CVE-2016-5419, CVE-2016-5420, CVE-2016-5421, CVE-2016-7141, CVE-2016-7167, CVE-2016-8615, CVE-2016-8616, CVE-2016-8617, CVE-2016-8618, CVE-2016-8619, CVE-2016-8620, CVE-2016-8621, CVE-2016-8622, CVE-2016-8623, CVE-2016-8624, CVE-2016-8625, CVE-2016-9586, CVE-2016-9594

GLSA: 201701-47