FreeBSD : powerdns -- multiple vulnerabilities (e3200958-dd6c-11e6-ae1b-002590263bf5)

High Nessus Plugin ID 96620


The remote FreeBSD host is missing one or more security-related updates.


PowerDNS reports :

2016-02: Crafted queries can cause abnormal CPU usage

2016-03: Denial of service via the web server

2016-04: Insufficient validation of TSIG signatures

2016-05: Crafted zone record can cause a denial of service


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 96620

File Name: freebsd_pkg_e3200958dd6c11e6ae1b002590263bf5.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/19

Modified: 2017/01/19

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:powerdns, p-cpe:/a:freebsd:freebsd:powerdns-recursor, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2017/01/18

Vulnerability Publication Date: 2016/12/15

Reference Information

CVE: CVE-2016-2120, CVE-2016-7068, CVE-2016-7072, CVE-2016-7073, CVE-2016-7074