FreeBSD : Ansible -- Command execution on Ansible controller from host (a93c3287-d8fd-11e6-be5c-001fbc0f280f)

High Nessus Plugin ID 96472

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

Computest reports :

Computest found and exploited several issues that allow a compromised host to execute commands on the Ansible controller and thus gain access to other hosts controlled by that controller.

Solution

Update the affected package.

See Also

https://www.computest.nl/advisories/CT-2017-0109_Ansible.txt

https://lwn.net/Articles/711357/

http://www.nessus.org/u?93be6c76

Plugin Details

Severity: High

ID: 96472

File Name: freebsd_pkg_a93c3287d8fd11e6be5c001fbc0f280f.nasl

Version: 3.6

Type: local

Published: 2017/01/13

Updated: 2019/04/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.3

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:ansible, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/01/12

Vulnerability Publication Date: 2017/01/09

Reference Information

CVE: CVE-2016-9587