openSUSE Security Update : wget (openSUSE-2017-9)

Medium Nessus Plugin ID 96278


The remote openSUSE host is missing a security update.


This update for wget fixes the following issues :

Security issues fixed :

- CVE-2016-7098: Fixed a potential race condition by creating files with .tmp ext and making them accessible to the current user only. (bsc#995964)

Non security issues fixed :

- bsc#1005091: Don't call xfree() on string returned by usr_error()

- bsc#1012677: Add support for enforcing TLSv1.1 and TLSv1.2 (TLS 1.2 support was already present, but it was not enforcable).

This update was imported from the SUSE:SLE-12:Update update project.


Update the affected wget packages.

See Also

Plugin Details

Severity: Medium

ID: 96278

File Name: openSUSE-2017-9.nasl

Version: $Revision: 3.1 $

Type: local

Agent: unix

Published: 2017/01/04

Modified: 2017/01/04

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P


Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:wget, p-cpe:/a:novell:opensuse:wget-debuginfo, p-cpe:/a:novell:opensuse:wget-debugsource, cpe:/o:novell:opensuse:42.1, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/01/03

Reference Information

CVE: CVE-2016-7098