openSUSE Security Update : MozillaThunderbird (openSUSE-2016-1531)

Medium Nessus Plugin ID 96246


The remote openSUSE host is missing a security update.


This update to Mozilla Thunderbird 45.6.0 fixes security issues and bugs.

In general, these flaws cannot be exploited through email in Thunderbird because scripting is disabled when reading mail, but are potentially risks in browser or browser-like contexts.

The following vulnerabilities were fixed: (boo#1015422)

- CVE-2016-9899: Use-after-free while manipulating DOM events and audio elements

- CVE-2016-9895: CSP bypass using marquee tag

- CVE-2016-9897: Memory corruption in libGLES

- CVE-2016-9898: Use-after-free in Editor while manipulating DOM subtrees

- CVE-2016-9900: Restricted external resources can be loaded by SVG images through data URLs

- CVE-2016-9904: Cross-origin information leak in shared atoms

- CVE-2016-9905: Crash in EnumerateSubDocuments

- CVE-2016-9893: Memory safety bugs fixed in Thunderbird 45.6

The following bugs were fixed :

- The system integration dialog was shown every time when starting Thunderbird


Update the affected MozillaThunderbird packages.

See Also

Plugin Details

Severity: Medium

ID: 96246

File Name: openSUSE-2016-1531.nasl

Version: $Revision: 3.3 $

Type: local

Agent: unix

Published: 2017/01/03

Modified: 2017/01/26

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:MozillaThunderbird, p-cpe:/a:novell:opensuse:MozillaThunderbird-buildsymbols, p-cpe:/a:novell:opensuse:MozillaThunderbird-debuginfo, p-cpe:/a:novell:opensuse:MozillaThunderbird-debugsource, p-cpe:/a:novell:opensuse:MozillaThunderbird-devel, p-cpe:/a:novell:opensuse:MozillaThunderbird-translations-common, p-cpe:/a:novell:opensuse:MozillaThunderbird-translations-other, cpe:/o:novell:opensuse:13.2, cpe:/o:novell:opensuse:42.1, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/12/30

Exploitable With

Core Impact

Reference Information

CVE: CVE-2016-9893, CVE-2016-9895, CVE-2016-9897, CVE-2016-9898, CVE-2016-9899, CVE-2016-9900, CVE-2016-9904, CVE-2016-9905