GLSA-201701-13 : HDF5: Multiple vulnerabilities

Medium Nessus Plugin ID 96244


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-13 (HDF5: Multiple vulnerabilities)

Multiple arbitrary code execution vulnerabilities have been discovered in HDF5. Please review the CVE identifiers referenced below for details.
Impact :

An attacker could execute arbitrary code with the privileges of the process via a maliciously crafted database file.
Workaround :

There is no known workaround at this time.


All HDF5 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sci-libs/hdf5-1.8.18'

See Also

Plugin Details

Severity: Medium

ID: 96244

File Name: gentoo_GLSA-201701-13.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/03

Modified: 2017/01/03

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C


Base Score: 8.6

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:hdf5, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/02

Reference Information

CVE: CVE-2016-4330, CVE-2016-4331, CVE-2016-4332, CVE-2016-4333

GLSA: 201701-13