FreeBSD : h2o -- Use-after-free vulnerability (d0b12952-cb86-11e6-906f-0cc47a065786)

High Nessus Plugin ID 96222


The remote FreeBSD host is missing a security-related update.


Kazuho Oku reports :

A use-after-free vulnerability exists in H2O up to and including version 2.0.4 / 2.1.0-beta3 that can be used by a remote attacker to mount DoS attacks and / or information theft.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 96222

File Name: freebsd_pkg_d0b12952cb8611e6906f0cc47a065786.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/03

Modified: 2017/01/03

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:h2o, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2016/12/29

Vulnerability Publication Date: 2016/09/09