Amazon Linux AMI : vim (ALAS-2016-779)

Medium Nessus Plugin ID 95935

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

A vulnerability was found in vim in how certain modeline options were treated. An attacker could craft a file that, when opened in vim with modelines enabled, could execute arbitrary commands with privileges of the user running vim. (modelines are disabled by default for root, and enabled by default for other users.)

Solution

Run 'yum update vim' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2016-779.html

Plugin Details

Severity: Medium

ID: 95935

File Name: ala_ALAS-2016-779.nasl

Version: 3.2

Type: local

Agent: unix

Published: 2016/12/20

Updated: 2018/04/18

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:vim-common, p-cpe:/a:amazon:linux:vim-debuginfo, p-cpe:/a:amazon:linux:vim-enhanced, p-cpe:/a:amazon:linux:vim-filesystem, p-cpe:/a:amazon:linux:vim-minimal, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2016/12/19

Reference Information

CVE: CVE-2016-1248

ALAS: 2016-779