ImageMagick 7.x < 7.0.3-9 ReadSGIImage() SGI File Handling DoS

High Nessus Plugin ID 95722


An application installed on the remote Windows host is affected by a denial of service vulnerability.


The version of ImageMagick installed on the remote Windows host is 7.x prior to 7.0.3-9. It is, therefore, affected by a denial of service vulnerability due to an out-of-bounds read error in the ReadSGIImage() function within file coders/sgi.c when handling iris info dimensions.
An unauthenticated, remote attacker can exploit this to crash a process linked against the library or possibly disclose memory contents.

Note that CVE-2016-9773 exists due to an incomplete fix for CVE-2016-9556.


Upgrade to ImageMagick version 7.0.3-9 or later. Note that you may also need to manually uninstall the vulnerable version from the system.

See Also

Plugin Details

Severity: High

ID: 95722

File Name: imagemagick_7_0_3_9.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2016/12/12

Modified: 2017/03/22

Dependencies: 38949

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND


Base Score: 7.1

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:imagemagick:imagemagick

Required KB Items: installed_sw/ImageMagick

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/12/05

Vulnerability Publication Date: 2016/11/16

Reference Information

CVE: CVE-2016-9556, CVE-2016-9773

BID: 94492

OSVDB: 147474

IAVB: 2016-B-0178