openSUSE Security Update : libXfixes (openSUSE-2016-1429)

High Nessus Plugin ID 95703


The remote openSUSE host is missing a security update.


This update for libXfixes fixes a security issue :

- insufficient validation of data from the X server could cause an integer overflow on 32 bit architectures (boo#1002995, CVE-2016-7944).


Update the affected libXfixes packages.

See Also

Plugin Details

Severity: High

ID: 95703

File Name: openSUSE-2016-1429.nasl

Version: $Revision: 3.3 $

Type: local

Agent: unix

Published: 2016/12/12

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libXfixes-debugsource, p-cpe:/a:novell:opensuse:libXfixes-devel, p-cpe:/a:novell:opensuse:libXfixes-devel-32bit, p-cpe:/a:novell:opensuse:libXfixes3, p-cpe:/a:novell:opensuse:libXfixes3-32bit, p-cpe:/a:novell:opensuse:libXfixes3-debuginfo, p-cpe:/a:novell:opensuse:libXfixes3-debuginfo-32bit, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/12/08

Reference Information

CVE: CVE-2016-7944