openSUSE Security Update : libXtst (openSUSE-2016-1422)

critical Nessus Plugin ID 95646

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote openSUSE host is missing a security update.

Description

This update of libXtst fixes the following security issue :

- malicious data sent from an untrusted or compromised X server could cause out of boundary memory access or endless loops (Denial of Service). (boo#1003012, CVE-2016-7951, CVE-2016-7952)

Solution

Update the affected libXtst packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1003012

Plugin Details

Severity: Critical

ID: 95646

File Name: openSUSE-2016-1422.nasl

Version: 2.5

Type: local

Agent: unix

Published: 12/8/2016

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:o:novell:opensuse:13.2:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libxtst-debugsource:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libxtst-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libxtst-devel-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libxtst6:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libxtst6-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libxtst6-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libxtst6-debuginfo-32bit:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 12/7/2016

Reference Information

CVE: CVE-2016-7951, CVE-2016-7952