openSUSE Security Update : libXrender (openSUSE-2016-1421)

High Nessus Plugin ID 95645


The remote openSUSE host is missing a security update.


This update of libXrender fixes the following issues :

- insufficient validation of data from the X server could cause out of boundary memory writes (boo#1003002, CVE-2016-7949, CVE-2016-7950)


Update the affected libXrender packages.

See Also

Plugin Details

Severity: High

ID: 95645

File Name: openSUSE-2016-1421.nasl

Version: $Revision: 2.3 $

Type: local

Agent: unix

Published: 2016/12/08

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libXrender-debugsource, p-cpe:/a:novell:opensuse:libXrender-devel, p-cpe:/a:novell:opensuse:libXrender-devel-32bit, p-cpe:/a:novell:opensuse:libXrender1, p-cpe:/a:novell:opensuse:libXrender1-32bit, p-cpe:/a:novell:opensuse:libXrender1-debuginfo, p-cpe:/a:novell:opensuse:libXrender1-debuginfo-32bit, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/12/07

Reference Information

CVE: CVE-2016-7949, CVE-2016-7950