openSUSE Security Update : nodejs4 (openSUSE-2016-1403)

High Nessus Plugin ID 95557


The remote openSUSE host is missing a security update.


This update for nodejs4 fixes the following issues :

Security issues fixed :

- CVE-2016-5180: c-ares: Fix for single-byte buffer overwrite (bsc#1007728).

Bug fixes :

- bsc#1009011: npm4 should provide versioned nodejs-npm and npm allowing nodejs-packaging to continue to function properly in Leap 42.2

This update was imported from the SUSE:SLE-12:Update update project.


Update the affected nodejs4 packages.

See Also

Plugin Details

Severity: High

ID: 95557

File Name: openSUSE-2016-1403.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2016/12/06

Modified: 2016/12/06

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:nodejs4, p-cpe:/a:novell:opensuse:nodejs4-debuginfo, p-cpe:/a:novell:opensuse:nodejs4-debugsource, p-cpe:/a:novell:opensuse:nodejs4-devel, p-cpe:/a:novell:opensuse:npm4, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/12/05

Reference Information

CVE: CVE-2016-5180