openSUSE Security Update : sudo (openSUSE-2016-1381)

Medium Nessus Plugin ID 95533


The remote openSUSE host is missing a security update.


This update for sudo fixes the following issues :

- fix two security vulnerabilities that allowed users to bypass sudo's NOEXEC functionality :

- noexec bypass via system() and popen() [CVE-2016-7032, bsc#1007766]

- noexec bypass via wordexp() [CVE-2016-7076, bsc#1007501]

Sudo was updated to the package from SUSE:SLE-12-SP2:Update, incorporating the following new feature :

- allow dynamic groups with sudo [fate#318850]

The following bug fixes are included :

- parse /proc/stat for boottime correctly [boo#899252]

- enable SASL authentication [boo#979531]


Update the affected sudo packages.

See Also

Plugin Details

Severity: Medium

ID: 95533

File Name: openSUSE-2016-1381.nasl

Version: $Revision: 3.3 $

Type: local

Agent: unix

Published: 2016/12/05

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C


Base Score: 7

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:sudo, p-cpe:/a:novell:opensuse:sudo-debuginfo, p-cpe:/a:novell:opensuse:sudo-debugsource, p-cpe:/a:novell:opensuse:sudo-devel, p-cpe:/a:novell:opensuse:sudo-test, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/12/02

Reference Information

CVE: CVE-2014-9680, CVE-2016-7032, CVE-2016-7076