openSUSE Security Update : bash (openSUSE-2016-1374) (Shellshock)

high Nessus Plugin ID 95529

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for bash fixes the following issues :

- CVE-2016-7543: Local attackers could have executed arbitrary commands via specially crafted SHELLOPTS+PS4 variables (bsc#1001299)

- CVE-2016-0634: Malicious hostnames could have allowed arbitrary command execution when $HOSTNAME was expanded in the prompt (bsc#1000396)

- CVE-2014-6277: More troubles with functions (bsc#898812, bsc#1001759)

- CVE-2014-6278: Code execution after original 6271 fix (bsc#898884)

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected bash packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1000396

https://bugzilla.opensuse.org/show_bug.cgi?id=1001299

https://bugzilla.opensuse.org/show_bug.cgi?id=1001759

https://bugzilla.opensuse.org/show_bug.cgi?id=898812

https://bugzilla.opensuse.org/show_bug.cgi?id=898884

Plugin Details

Severity: High

ID: 95529

File Name: openSUSE-2016-1374.nasl

Version: 3.7

Type: local

Agent: unix

Published: 12/5/2016

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.4

Temporal Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:novell:opensuse:42.1:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:bash:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:bash-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:bash-debuginfo-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:bash-debugsource:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:bash-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:bash-lang:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:bash-loadables:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:bash-loadables-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libreadline6:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libreadline6-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libreadline6-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libreadline6-debuginfo-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:readline-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:readline-devel-32bit:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/1/2016

Exploitable With

Core Impact

Metasploit (CUPS Filter Bash Environment Variable Code Injection (Shellshock))

Reference Information

CVE: CVE-2016-0634, CVE-2016-7543, CVE-2014-6277, CVE-2014-6278

IAVA: 2014-A-0142