FreeBSD : ImageMagick -- heap overflow vulnerability (19d35b0f-ba73-11e6-b1cf-14dae9d210b8)

Medium Nessus Plugin ID 95499


The remote FreeBSD host is missing one or more security-related updates.


Bastien Roucaries reports :

Imagemagick before 3cbfb163cff9e5b8cdeace8312e9bfee810ed02b suffer from a heap overflow in WaveletDenoiseImage(). This problem is easily trigerrable from a Perl script.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 95499

File Name: freebsd_pkg_19d35b0fba7311e6b1cf14dae9d210b8.nasl

Version: $Revision: 3.4 $

Type: local

Published: 2016/12/05

Modified: 2017/07/05

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P


Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:ImageMagick, p-cpe:/a:freebsd:freebsd:ImageMagick-nox11, p-cpe:/a:freebsd:freebsd:ImageMagick7, p-cpe:/a:freebsd:freebsd:ImageMagick7-nox11, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2016/12/04

Vulnerability Publication Date: 2016/11/13

Reference Information

CVE: CVE-2016-9298