SUSE SLED12 / SLES12 Security Update : util-linux (SUSE-SU-2016:2954-1)

Medium Nessus Plugin ID 95424

Synopsis

The remote SUSE host is missing one or more security updates.

Description

This update for util-linux fixes the following issues :

- Consider redundant slashes when comparing paths (bsc#982331, util-linux-libmount-ignore-redundant-slashes.patch, affects backport of util-linux-libmount-cifs-is_mounted.patch).

- Use upstream compatibility patches for
--show-pt-geometry with obsolescence and deprecation warning (bsc#990531)

- Replace cifs mount detection patch with upstream one that covers all cases (bsc#987176).

- Reuse existing loop device to prevent possible data corruption when multiple -o loop are used to mount a single file (bsc#947494)

- Safe loop re-use in libmount, mount and losetup (bsc#947494)

- UPSTREAM DIVERGENCE!!! losetup -L continues to use SLE12 SP1 and SP2 specific meaning

--logical-blocksize instead of upstream --nooverlap (bsc#966891).

- Make release-dependent conflict with old sysvinit-tools SLE specific, as it is required only for SLE 11 upgrade, and breaks openSUSE staging builds (bsc#994399).

- Extended partition loop in MBR partition table leads to DoS (bsc#988361, CVE-2016-5011)

Note that Tenable Network Security has extracted the preceding description block directly from the SUSE security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Workstation Extension 12-SP2:zypper in -t patch SUSE-SLE-WE-12-SP2-2016-1729=1

SUSE Linux Enterprise Software Development Kit 12-SP2:zypper in -t patch SUSE-SLE-SDK-12-SP2-2016-1729=1

SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:zypper in -t patch SUSE-SLE-RPI-12-SP2-2016-1729=1

SUSE Linux Enterprise Server 12-SP2:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2016-1729=1

SUSE Linux Enterprise Desktop 12-SP2:zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2016-1729=1

To bring your system up-to-date, use 'zypper patch'.

See Also

https://bugzilla.suse.com/show_bug.cgi?id=947494

https://bugzilla.suse.com/show_bug.cgi?id=966891

https://bugzilla.suse.com/show_bug.cgi?id=982331

https://bugzilla.suse.com/show_bug.cgi?id=987176

https://bugzilla.suse.com/show_bug.cgi?id=988361

https://bugzilla.suse.com/show_bug.cgi?id=990531

https://bugzilla.suse.com/show_bug.cgi?id=994399

https://www.suse.com/security/cve/CVE-2016-5011/

http://www.nessus.org/u?9508626e

Plugin Details

Severity: Medium

ID: 95424

File Name: suse_SU-2016-2954-1.nasl

Version: 3.7

Type: local

Agent: unix

Published: 2016/12/01

Updated: 2018/11/29

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.7

Temporal Score: 3.5

Vector: CVSS2#AV:L/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:P/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:libblkid1, p-cpe:/a:novell:suse_linux:libblkid1-debuginfo, p-cpe:/a:novell:suse_linux:libfdisk1, p-cpe:/a:novell:suse_linux:libfdisk1-debuginfo, p-cpe:/a:novell:suse_linux:libmount1, p-cpe:/a:novell:suse_linux:libmount1-debuginfo, p-cpe:/a:novell:suse_linux:libsmartcols1, p-cpe:/a:novell:suse_linux:libsmartcols1-debuginfo, p-cpe:/a:novell:suse_linux:libuuid-devel, p-cpe:/a:novell:suse_linux:libuuid1, p-cpe:/a:novell:suse_linux:libuuid1-debuginfo, p-cpe:/a:novell:suse_linux:python-libmount, p-cpe:/a:novell:suse_linux:python-libmount-debuginfo, p-cpe:/a:novell:suse_linux:python-libmount-debugsource, p-cpe:/a:novell:suse_linux:util-linux, p-cpe:/a:novell:suse_linux:util-linux-debuginfo, p-cpe:/a:novell:suse_linux:util-linux-debugsource, p-cpe:/a:novell:suse_linux:util-linux-systemd, p-cpe:/a:novell:suse_linux:util-linux-systemd-debuginfo, p-cpe:/a:novell:suse_linux:util-linux-systemd-debugsource, p-cpe:/a:novell:suse_linux:uuidd, p-cpe:/a:novell:suse_linux:uuidd-debuginfo, cpe:/o:novell:suse_linux:12

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/11/30

Reference Information

CVE: CVE-2016-5011