Mozilla Firefox < 50.0 Multiple Vulnerabilities (macOS)

High Nessus Plugin ID 94958

Synopsis

The remote macOS or Mac OS X host contains a web browser that is affected by multiple vulnerabilities.

Description

The version of Mozilla Firefox installed on the remote macOS or Mac OS X host is prior to 50.0. It is, therefore, affected by multiple vulnerabilities, the majority of which are remote code execution vulnerabilities. An unauthenticated, remote attacker can exploit these vulnerabilities by convincing a user to visit a specially crafted website, resulting in the execution of arbitrary code in the context of the current user.

Solution

Upgrade to Mozilla Firefox version 50.0 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2016-89/

Plugin Details

Severity: High

ID: 94958

File Name: macosx_firefox_50_0.nasl

Version: 1.6

Type: local

Agent: macosx

Published: 2016/11/18

Updated: 2018/07/14

Dependencies: 55417

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/11/15

Vulnerability Publication Date: 2016/11/15

Reference Information

CVE: CVE-2016-5289, CVE-2016-5290, CVE-2016-5291, CVE-2016-5292, CVE-2016-5296, CVE-2016-5297, CVE-2016-9063, CVE-2016-9064, CVE-2016-9066, CVE-2016-9067, CVE-2016-9068, CVE-2016-9069, CVE-2016-9070, CVE-2016-9071, CVE-2016-9073, CVE-2016-9074, CVE-2016-9075, CVE-2016-9076, CVE-2016-9077

BID: 94335, 94336, 94337, 94339, 94341

MFSA: 2016-89