CVE-2016-9075

HIGH

Description

An issue where WebExtensions can use the mozAddonManager API to elevate privilege due to privileged pages being allowed in the permissions list. This allows a malicious extension to then install additional extensions without explicit user permission. This vulnerability affects Firefox < 50.

References

http://www.securityfocus.com/bid/94337

http://www.securitytracker.com/id/1037298

https://bugzilla.mozilla.org/show_bug.cgi?id=1295324

https://www.mozilla.org/security/advisories/mfsa2016-89/

Details

Source: MITRE

Published: 2018-06-11

Updated: 2018-08-08

Type: CWE-264

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: (AV:N/AC:L/Au:N/C:P/I:P/A:P)

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL