Adobe Connect < 9.5.7 event_registration.html Multiple Parameter XSS (APSB16-35)

Medium Nessus Plugin ID 94759

Synopsis

The remote web server contains an application that is affected by a cross-site scripting vulnerability.

Description

The version of Adobe Connect running on the remote host is prior to 9.5.7. It is, therefore, affected by a cross-site scripting (XSS) vulnerability in the event_registration.html script due to a failure to properly sanitize user-supplied input to the 'firstname', 'lastname', and 'companyname' parameters. An unauthenticated, remote attacker can exploit this issue, via a specially crafted request, to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe Connect version 9.5.7 or later.

See Also

https://helpx.adobe.com/security/products/connect/apsb16-35.html

Plugin Details

Severity: Medium

ID: 94759

File Name: adobe_connect_apsb16-35.nasl

Version: $Revision: 1.5 $

Type: remote

Published: 2016/11/14

Modified: 2017/07/13

Dependencies: 94760

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:adobe:connect

Required KB Items: installed_sw/Adobe Connect

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/11/08

Vulnerability Publication Date: 2016/11/08

Reference Information

CVE: CVE-2016-7851

BID: 94152

EDB-ID: 40742