FreeBSD : Axis2 -- Security vulnerabilities on dependency Apache HttpClient (ac18046c-9b08-11e6-8011-005056925db4)

Medium Nessus Plugin ID 94419


The remote FreeBSD host is missing a security-related update.


Apache Axis2 reports :

Apache Axis2 1.7.4 is a maintenance release that includes fixes for several issues, including the following security issues : Session fixation (AXIS2-4739) and XSS (AXIS2-5683) vulnerabilities affecting the admin console. A dependency on an Apache HttpClient version affected by known security vulnerabilities (CVE-2012-6153 and CVE-2014-3577); see AXIS2-5757.


Update the affected package.

See Also

Plugin Details

Severity: Medium

ID: 94419

File Name: freebsd_pkg_ac18046c9b0811e68011005056925db4.nasl

Version: $Revision: 2.1 $

Type: local

Published: 2016/10/31

Modified: 2016/10/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:axis2, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2016/10/28

Vulnerability Publication Date: 2012/12/06

Reference Information

CVE: CVE-2012-6153, CVE-2014-3577