openSUSE Security Update : postgresql94 (openSUSE-2016-1161)

Medium Nessus Plugin ID 93997

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for postgresql94 to version 9.4.9 fixes the several issues.

These security issues were fixed :

- CVE-2016-5423: CASE/WHEN with inlining can cause untrusted pointer dereference (bsc#993454).

- CVE-2016-5424: Fix client programs' handling of special characters in database and role names (bsc#993453).

This non-security issue was fixed :

- bsc#973660: Added 'Requires: timezone' to Service Pack

For additional non-security issues please refer to

- http://www.postgresql.org/docs/9.4/static/release-9-4-9.html

- http://www.postgresql.org/docs/9.4/static/release-9-4-8.html

- http://www.postgresql.org/docs/9.4/static/release-9-4-7.html

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected postgresql94 packages.

See Also

https://www.postgresql.org/docs/9.4/release-9-4-7.html

https://www.postgresql.org/docs/9.4/release-9-4-8.html

https://www.postgresql.org/docs/9.4/release-9-4-9.html

https://bugzilla.opensuse.org/show_bug.cgi?id=973660

https://bugzilla.opensuse.org/show_bug.cgi?id=993453

https://bugzilla.opensuse.org/show_bug.cgi?id=993454

Plugin Details

Severity: Medium

ID: 93997

File Name: openSUSE-2016-1161.nasl

Version: 2.6

Type: local

Agent: unix

Published: 2016/10/12

Modified: 2018/12/18

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.3

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libecpg6, p-cpe:/a:novell:opensuse:libecpg6-32bit, p-cpe:/a:novell:opensuse:libecpg6-debuginfo, p-cpe:/a:novell:opensuse:libecpg6-debuginfo-32bit, p-cpe:/a:novell:opensuse:libpq5, p-cpe:/a:novell:opensuse:libpq5-32bit, p-cpe:/a:novell:opensuse:libpq5-debuginfo, p-cpe:/a:novell:opensuse:libpq5-debuginfo-32bit, p-cpe:/a:novell:opensuse:postgresql94, p-cpe:/a:novell:opensuse:postgresql94-contrib, p-cpe:/a:novell:opensuse:postgresql94-contrib-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-debugsource, p-cpe:/a:novell:opensuse:postgresql94-devel, p-cpe:/a:novell:opensuse:postgresql94-devel-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-libs-debugsource, p-cpe:/a:novell:opensuse:postgresql94-plperl, p-cpe:/a:novell:opensuse:postgresql94-plperl-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-plpython, p-cpe:/a:novell:opensuse:postgresql94-plpython-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-pltcl, p-cpe:/a:novell:opensuse:postgresql94-pltcl-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-server, p-cpe:/a:novell:opensuse:postgresql94-server-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-test, cpe:/o:novell:opensuse:42.1

Patch Publication Date: 2016/10/06

Reference Information

CVE: CVE-2016-5423, CVE-2016-5424