FreeBSD : redis -- sensitive information leak through command history file (fa175f30-8c75-11e6-924a-60a44ce6887b)

Low Nessus Plugin ID 93991

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

Redis team reports :

The redis-cli history file (in linenoise) is created with the default OS umask value which makes it world readable in most systems and could potentially expose authentication credentials to other users.

Solution

Update the affected packages.

See Also

https://github.com/antirez/redis/pull/1418

https://github.com/antirez/redis/issues/3284

http://www.nessus.org/u?753568fb

Plugin Details

Severity: Low

ID: 93991

File Name: freebsd_pkg_fa175f308c7511e6924a60a44ce6887b.nasl

Version: $Revision: 2.2 $

Type: local

Published: 2016/10/12

Modified: 2016/10/19

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:N/A:N

CVSSv3

Base Score: 3.3

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:redis, p-cpe:/a:freebsd:freebsd:redis-devel, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2016/10/11

Vulnerability Publication Date: 2013/11/30

Reference Information

CVE: CVE-2013-7458